{"answers":{"affected":"8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-6927 in the wild and no public exploit code.","fix":"Upgrade drupal/core to a fixed version for your release line: 7.57 or 8.4.5.","what":"CVE-2017-6927 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-6927 and fix it if it is affected.\n\nWhat it is: CVE-2017-6927 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-6927 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 7.0; fixed in 7.57\n- drupal/core (Packagist): affected from 7.0; fixed in 7.57\n- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5\n- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5\n- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57\n- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57\n- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5\n- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6927/ (Markdown: https://insights.sbomify.com/CVE-2017-6927/index.md)","id":"CVE-2017-6927","markdown":"https://insights.sbomify.com/CVE-2017-6927/index.md","name":"CVE-2017-6927","record":{"aliases":["GHSA-585j-5449-mf5m","UBUNTU-CVE-2017-6927"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal core","requires_auth":"none","summary":"An XSS vulnerability in Drupal's JavaScript escaping function allows attackers to inject malicious HTML, potentially leading to code execution or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"drupal","vendor":"drupal"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal cross-site scripting vulnerability","id":"CVE-2017-6927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","drupal:drupal"],"type":"xss","year":"2017"},"n_packages":8,"n_references":4,"next":{"headline":"Drupal access bypass vulnerability","id":"CVE-2017-6928"},"packages":[{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["8.4.5"],"introduced":["8.4.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["8.4.5"],"introduced":["8.4.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["8.4.5"],"introduced":["8.4.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-585j-5449-mf5m"},{"ecosystem":"Packagist","fixed":["8.4.5"],"introduced":["8.4.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-585j-5449-mf5m"}],"prev":{"headline":"Drupal Comment reply form allows access to restricted content","id":"CVE-2017-6926"},"products":["Drupal Core"],"published":"2018-03-01","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Drupal.org"]},"summary":"An XSS vulnerability in Drupal's JavaScript escaping function allows attackers to inject malicious HTML, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2017-6927/"}