# CVE-2017-6927: Drupal cross-site scripting vulnerability

> An XSS vulnerability in Drupal's JavaScript escaping function allows attackers to inject malicious HTML, potentially leading to code execution or account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-585j-5449-mf5m, UBUNTU-CVE-2017-6927

## What is CVE-2017-6927?

CVE-2017-6927 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-6927?

8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.57 |
| `drupal/core` | Packagist | From 7.0 | 7.57 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 7.0 | 7.57 |
| `drupal/drupal` | Packagist | From 7.0 | 7.57 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2017-6927?

Upgrade drupal/core to a fixed version for your release line: 7.57 or 8.4.5.

## Is CVE-2017-6927 being exploited?

There is no known exploitation of CVE-2017-6927 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6927 and fix it if it is affected.

What it is: CVE-2017-6927 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-6927 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.57
- drupal/core (Packagist): affected from 7.0; fixed in 7.57
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6927/ (Markdown: https://insights.sbomify.com/CVE-2017-6927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6927
- OSV: https://osv.dev/vulnerability/CVE-2017-6927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6927/
Summaries are generated and may contain mistakes; the official description above is the record.
