{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-6928 in the wild and no public exploit code.","fix":"Upgrade drupal/core to 7.57 or later.","what":"CVE-2017-6928 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-6928 and fix it if it is affected.\n\nWhat it is: CVE-2017-6928 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-6928 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 7.0; fixed in 7.57\n- drupal/core (Packagist): affected from 7.0; fixed in 7.57\n- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57\n- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6928/ (Markdown: https://insights.sbomify.com/CVE-2017-6928/index.md)","id":"CVE-2017-6928","markdown":"https://insights.sbomify.com/CVE-2017-6928/index.md","name":"CVE-2017-6928","record":{"aliases":["GHSA-66mv-q8r2-hj8w","UBUNTU-CVE-2017-6928"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Drupal core","requires_auth":"low_privilege","summary":"An access bypass vulnerability in Drupal core allows unauthorized users to view or download private files under specific module conflict conditions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"drupal","vendor":"drupal"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal access bypass vulnerability","id":"CVE-2017-6928","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","drupal:drupal"],"type":"missing_authorization","year":"2017"},"n_packages":4,"n_references":3,"next":{"headline":"Drupal cross site scripting vulnerability","id":"CVE-2017-6929"},"packages":[{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-66mv-q8r2-hj8w"},{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-66mv-q8r2-hj8w"},{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-66mv-q8r2-hj8w"},{"ecosystem":"Packagist","fixed":["7.57"],"introduced":["7.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-66mv-q8r2-hj8w"}],"prev":{"headline":"Drupal cross-site scripting vulnerability","id":"CVE-2017-6927"},"products":["Drupal Core"],"published":"2018-03-01","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Drupal.org"]},"summary":"An access bypass vulnerability in Drupal core allows unauthorized users to view or download private files under specific module conflict conditions.","url":"https://insights.sbomify.com/CVE-2017-6928/"}