# CVE-2017-6928: Drupal access bypass vulnerability

> An access bypass vulnerability in Drupal core allows unauthorized users to view or download private files under specific module conflict conditions.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-66mv-q8r2-hj8w, UBUNTU-CVE-2017-6928

## What is CVE-2017-6928?

CVE-2017-6928 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2017-6928?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.57 |
| `drupal/core` | Packagist | From 7.0 | 7.57 |
| `drupal/drupal` | Packagist | From 7.0 | 7.57 |
| `drupal/drupal` | Packagist | From 7.0 | 7.57 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2017-6928?

Upgrade drupal/core to 7.57 or later.

## Is CVE-2017-6928 being exploited?

There is no known exploitation of CVE-2017-6928 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6928 and fix it if it is affected.

What it is: CVE-2017-6928 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6928 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.57
- drupal/core (Packagist): affected from 7.0; fixed in 7.57
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6928/ (Markdown: https://insights.sbomify.com/CVE-2017-6928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6928
- OSV: https://osv.dev/vulnerability/CVE-2017-6928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6928/
Summaries are generated and may contain mistakes; the official description above is the record.
