# CVE-2017-6930: Drupal access bypass vulnerability

> Attackers can bypass node access controls on multilingual Drupal sites using Content Translation and specific node access modules.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3327-jr93-7hq3

## What is CVE-2017-6930?

CVE-2017-6930 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().

## Which versions are affected by CVE-2017-6930?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |

Products: Drupal Drupal.

## How do I fix CVE-2017-6930?

Upgrade drupal/core to 8.4.5 or later.

## Is CVE-2017-6930 being exploited?

There is no known exploitation of CVE-2017-6930 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6930 and fix it if it is affected.

What it is: CVE-2017-6930 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6930 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6930/ (Markdown: https://insights.sbomify.com/CVE-2017-6930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6930
- OSV: https://osv.dev/vulnerability/CVE-2017-6930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6930/
Summaries are generated and may contain mistakes; the official description above is the record.
