# CVE-2017-6931: Drupal Settings Tray access bypass

> Attackers can modify unauthorized data via the Settings Tray module in Drupal core, requiring an upgrade to fix.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7ffh-cjvg-fpr4

## What is CVE-2017-6931?

CVE-2017-6931 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2017-6931?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |

Products: Drupal Drupal.

## How do I fix CVE-2017-6931?

Upgrade drupal/core to 8.4.5 or later.

## Is CVE-2017-6931 being exploited?

There is no known exploitation of CVE-2017-6931 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6931 and fix it if it is affected.

What it is: CVE-2017-6931 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6931 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6931/ (Markdown: https://insights.sbomify.com/CVE-2017-6931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6931
- OSV: https://osv.dev/vulnerability/CVE-2017-6931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6931/
Summaries are generated and may contain mistakes; the official description above is the record.
