CVE-2017-6954 BuddyPress Docs plugin Improper Privilege Management
Authenticated users can modify other users' documents in the BuddyPress Docs plugin due to missing permission checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-6954?
CVE-2017-6954 is a medium-severity missing authorization vulnerability in n/a, published on 17 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in includes/component.php in the BuddyPress Docs plugin before 1.9.3 for WordPress. It is possible for authenticated users to edit documents of other users without proper permissions.
Weakness: CWE-269
Which versions are affected by CVE-2017-6954?
2 open source packages ship an affected version, including buddypress/buddypress. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
buddypress/buddypress Packagist | All versions | 1.9.3 |
buddypress/buddypress Packagist | All versions | 1.9.3 |
Products include Buddypress Buddypress.
How do I fix CVE-2017-6954?
Upgrade buddypress/buddypress to 1.9.3 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2017-6954 being exploited?
There is no known exploitation of CVE-2017-6954 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2024-10011 BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal
- CVE-2021-21389 BuddyPress privilege escalation via REST API
- CVE-2020-5244 Private data exposure via REST API in BuddyPress
- CVE-2012-2109 SQL injection in n/a
- CVE-2025-23798 WordPress Mass Messaging in BuddyPress Plugin <= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-9wf6-88x4-6xvj.