{"answers":{"affected":"2 open source packages ship an affected version, including buddypress/buddypress. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-6954 in the wild and no public exploit code.","fix":"Upgrade buddypress/buddypress to 1.9.3 or later.","what":"CVE-2017-6954 is a medium-severity missing authorization vulnerability in n/a, published on 17 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-6954 and fix it if it is affected.\n\nWhat it is: CVE-2017-6954 is a medium-severity missing authorization vulnerability in n/a, published on 17 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-6954 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- buddypress/buddypress (Packagist): affected all versions; fixed in 1.9.3\n- buddypress/buddypress (Packagist): affected all versions; fixed in 1.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6954/ (Markdown: https://insights.sbomify.com/CVE-2017-6954/index.md)","id":"CVE-2017-6954","markdown":"https://insights.sbomify.com/CVE-2017-6954/index.md","name":"CVE-2017-6954","record":{"aliases":["GHSA-9wf6-88x4-6xvj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated users can modify other users' documents in the BuddyPress Docs plugin due to missing permission checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"buddypress","vendor":"buddypress"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"An issue was discovered in includes/component.php in the BuddyPress Docs plugin before 1.9.3 for WordPress. It is possible for authenticated users to edit documents of other users without proper permissions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"BuddyPress Docs plugin Improper Privilege Management","id":"CVE-2017-6954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Business logic in n/a","id":"CVE-2017-6955"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"buddypress/buddypress","purl":null,"source":"GHSA-9wf6-88x4-6xvj"},{"ecosystem":"Packagist","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"buddypress/buddypress","purl":"pkg:composer/buddypress/buddypress","source":"GHSA-9wf6-88x4-6xvj"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-6953"},"products":["n/a"],"published":"2017-03-17","related":[{"cvss_score":8.1,"headline":"BuddyPress \u003c= 14.1.0 - Authenticated (Subscriber+) Directory Traversal","id":"CVE-2024-10011","kev_date_added":null,"published":"2024-10-25"},{"cvss_score":8.1,"headline":"BuddyPress privilege escalation via REST API","id":"CVE-2021-21389","kev_date_added":null,"published":"2021-03-26"},{"cvss_score":8,"headline":"Private data exposure via REST API in BuddyPress","id":"CVE-2020-5244","kev_date_added":null,"published":"2020-02-24"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2012-2109","kev_date_added":null,"published":"2012-09-04"},{"cvss_score":7.1,"headline":"WordPress Mass Messaging in BuddyPress Plugin \u003c= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-23798","kev_date_added":null,"published":"2025-01-22"},{"cvss_score":6.5,"headline":"WordPress BuddyPress Plugin \u003c= 11.3.1 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-50880","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":6.5,"headline":"Missing authorization in n/a","id":"CVE-2014-1889","kev_date_added":null,"published":"2018-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated users can modify other users' documents in the BuddyPress Docs plugin due to missing permission checks.","url":"https://insights.sbomify.com/CVE-2017-6954/"}