CVE-2017-7214 OpenStack Nova logs sensitive context from notification exceptions

Critical 9.8 Published Updated

Attackers with log access can view sensitive credentials and tokens in OpenStack Nova error logs due to improper exception handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-7214?

CVE-2017-7214 is a critical vulnerability in n/a, published on 21 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in exception_wrapper.py in OpenStack Nova 13.x through 13.1.3, 14.x through 14.0.4, and 15.x through 15.0.1. Legacy notification exception contexts appearing in ERROR level logs may include sensitive information such as account passwords and authorization tokens.

Weakness: CWE-532

Which versions are affected by CVE-2017-7214?

7 open source packages ship an affected version, including nova. It affects 1 product.

PackageAffectedFixed in
nova PyPIFrom 13.0.013.1.4, 14.0.5, 15.0.2
nova PyPIFrom 13.0.013.1.4
nova PyPIFrom 13.0.013.1.4
nova PyPIFrom 14.0.014.0.5
nova PyPIFrom 14.0.014.0.5
nova PyPIFrom 15.0.115.0.2
1 more packages
nova PyPIFrom 15.0.115.0.2
Linux distribution packages (33)
openstack-nova Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-api Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-cells Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-cert Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-common Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-compute Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-conductor Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-console Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-migration Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-network Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-novncproxy Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-placement-api Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-scheduler Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-serialproxy Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
openstack-nova-spicehtml5proxy Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
python-nova Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
python-nova-tests Red Hat:openstack:10::el7All versions1:14.0.6-2.el7ost
python-novaclient Red Hat:openstack:10::el7All versions1:6.0.0-3.el7ost
openstack-nova Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-api Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-cells Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-cert Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-common Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-compute Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-conductor Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-console Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-migration Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-network Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-novncproxy Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-scheduler Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-serialproxy Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
openstack-nova-spicehtml5proxy Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost
python-nova Red Hat:openstack:9::el7All versions1:13.1.4-1.el7ost

Products include Openstack Nova.

How do I fix CVE-2017-7214?

Upgrade nova to a fixed version for your release line: 13.1.4, 14.0.5 or 15.0.2.

Is CVE-2017-7214 being exploited?

There is no known exploitation of CVE-2017-7214 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2017-7214, GHSA-f4g4-cj8f-3cr9, PYSEC-2026-432, RHSA-2017:1508, RHSA-2017:1595.

Is CVE-2017-7214 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free