CVE-2017-7235 cfscrape Improper Input Validation vulnerability
A malicious website can execute arbitrary Python code on users of the cloudflare-scrape library by crafting a specific page response.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-7235?
CVE-2017-7235 is a high-severity code injection vulnerability in n/a, published on 23 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Weakness: CWE-20
Which versions are affected by CVE-2017-7235?
3 open source packages ship an affected version, including cfscrape. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cfscrape PyPI | From 1.6.6 | 1.8.0 |
cfscrape PyPI | From 1.6.6 | 1.8.0 |
cfscrape PyPI | From 1.6.6 | 1.8.0 |
Products include Cloudflare-Scrape Project Cloudflare-Scrape.
How do I fix CVE-2017-7235?
Upgrade cfscrape to 1.8.0 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2017-7235 being exploited?
There is no known exploitation of CVE-2017-7235 in the wild and no public exploit code.
Sources
Also known as GHSA-5mc5-5j6c-qmf9, PYSEC-2017-7.