{"answers":{"affected":"3 open source packages ship an affected version, including cfscrape. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7235 in the wild and no public exploit code.","fix":"Upgrade cfscrape to 1.8.0 or later.","what":"CVE-2017-7235 is a high-severity code injection vulnerability in n/a, published on 23 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7235 and fix it if it is affected.\n\nWhat it is: CVE-2017-7235 is a high-severity code injection vulnerability in n/a, published on 23 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-7235 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cfscrape (PyPI): affected from 1.6.6; fixed in 1.8.0\n- cfscrape (PyPI): affected from 1.6.6; fixed in 1.8.0\n- cfscrape (PyPI): affected from 1.6.6; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7235/ (Markdown: https://insights.sbomify.com/CVE-2017-7235/index.md)","id":"CVE-2017-7235","markdown":"https://insights.sbomify.com/CVE-2017-7235/index.md","name":"CVE-2017-7235","record":{"aliases":["GHSA-5mc5-5j6c-qmf9","PYSEC-2017-7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python scraping library","requires_auth":"none","summary":"A malicious website can execute arbitrary Python code on users of the cloudflare-scrape library by crafting a specific page response.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cloudflare-scrape","vendor":"cloudflare-scrape_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"cfscrape Improper Input Validation vulnerability","id":"CVE-2017-7235","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"SQL injection in n/a","id":"CVE-2017-7236"},"packages":[{"ecosystem":"PyPI","fixed":["1.8.0"],"introduced":["1.6.6"],"last_affected":[],"package":"cfscrape","purl":null,"source":"GHSA-5mc5-5j6c-qmf9"},{"ecosystem":"PyPI","fixed":["1.8.0"],"introduced":["1.6.6"],"last_affected":[],"package":"cfscrape","purl":"pkg:pypi/cfscrape","source":"GHSA-5mc5-5j6c-qmf9"},{"ecosystem":"PyPI","fixed":["1.8.0"],"introduced":["1.6.6"],"last_affected":[],"package":"cfscrape","purl":"pkg:pypi/cfscrape","source":"PYSEC-2017-7"}],"prev":{"headline":"Django open redirect","id":"CVE-2017-7234"},"products":["n/a"],"published":"2017-03-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A malicious website can execute arbitrary Python code on users of the cloudflare-scrape library by crafting a specific page response.","url":"https://insights.sbomify.com/CVE-2017-7235/"}