# CVE-2017-7235: cfscrape Improper Input Validation vulnerability

> A malicious website can execute arbitrary Python code on users of the cloudflare-scrape library by crafting a specific page response.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5mc5-5j6c-qmf9, PYSEC-2017-7

## What is CVE-2017-7235?

CVE-2017-7235 is a high-severity code injection vulnerability in n/a, published on 23 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-7235?

3 open source packages ship an affected version, including cfscrape. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cfscrape` | PyPI | From 1.6.6 | 1.8.0 |
| `cfscrape` | PyPI | From 1.6.6 | 1.8.0 |
| `cfscrape` | PyPI | From 1.6.6 | 1.8.0 |

Products: Cloudflare-Scrape Project Cloudflare-Scrape.

## How do I fix CVE-2017-7235?

Upgrade cfscrape to 1.8.0 or later.

## Is CVE-2017-7235 being exploited?

There is no known exploitation of CVE-2017-7235 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7235 and fix it if it is affected.

What it is: CVE-2017-7235 is a high-severity code injection vulnerability in n/a, published on 23 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7235 in the wild and no public exploit code.

Affected packages and fixed versions:
- cfscrape (PyPI): affected from 1.6.6; fixed in 1.8.0
- cfscrape (PyPI): affected from 1.6.6; fixed in 1.8.0
- cfscrape (PyPI): affected from 1.6.6; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7235/ (Markdown: https://insights.sbomify.com/CVE-2017-7235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7235
- OSV: https://osv.dev/vulnerability/CVE-2017-7235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7235/
Summaries are generated and may contain mistakes; the official description above is the record.
