# CVE-2017-7266: Netflix Security Monkey Open Redirect vulnerability

> Attackers can redirect users to malicious sites via the logout parameter, potentially facilitating phishing attacks against Security Monkey users.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j6jq-3q8p-xgg6, PYSEC-2026-919

## What is CVE-2017-7266?

CVE-2017-7266 is a medium-severity vulnerability in n/a, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Netflix Security Monkey before 0.8.0 has an Open Redirect. The logout functionality accepted the "next" parameter which then redirects to any domain irrespective of the Host header.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-7266?

3 open source packages ship an affected version, including security-monkey and security_monkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `security-monkey` | PyPI | All versions | 0.8.0 |
| `security-monkey` | PyPI | All versions | 0.8.0 |
| `security_monkey` | PyPI | All versions | 0.8.0 |

Products: Netflix Security Monkey.

## How do I fix CVE-2017-7266?

Upgrade security-monkey to 0.8.0 or later.

## Is CVE-2017-7266 being exploited?

There is no known exploitation of CVE-2017-7266 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7266 and fix it if it is affected.

What it is: CVE-2017-7266 is a medium-severity vulnerability in n/a, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7266 in the wild and no public exploit code.

Affected packages and fixed versions:
- security-monkey (PyPI): affected all versions; fixed in 0.8.0
- security-monkey (PyPI): affected all versions; fixed in 0.8.0
- security_monkey (PyPI): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7266/ (Markdown: https://insights.sbomify.com/CVE-2017-7266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7266
- OSV: https://osv.dev/vulnerability/CVE-2017-7266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7266/
Summaries are generated and may contain mistakes; the official description above is the record.
