{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7272 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-7272 is a high-severity server-side request forgery vulnerability in Php Php, published on 27 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7272 and fix it if it is affected.\n\nWhat it is: CVE-2017-7272 is a high-severity server-side request forgery vulnerability in Php Php, published on 27 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-7272 in the wild and no public exploit code.\n\nAffected product: Php Php. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7272/ (Markdown: https://insights.sbomify.com/CVE-2017-7272/index.md)","id":"CVE-2017-7272","markdown":"https://insights.sbomify.com/CVE-2017-7272/index.md","name":"CVE-2017-7272","record":{"aliases":["GHSA-943r-xvqq-r4rh","SUSE-SU-2017:1709-1","UBUNTU-CVE-2017-7272"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP language","requires_auth":"none","summary":"An attacker can bypass port restrictions in PHP applications using fsockopen by specifying a port in the hostname argument, leading to Server-Side Request Forgery.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"PHP through 7.1.11 enables potential SSRF in applications that accept an fsockopen or pfsockopen hostname argument with an expectation that the port number is constrained. Because a :port syntax is recognized, fsockopen will use the port number that is specified in the hostname argument, instead of the port number in the second argument of the function.","ecosystems":["SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Software Development Kit 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-side request forgery in n/a","id":"CVE-2017-7272","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"php:php","products":["php:php"],"type":"ssrf","year":"2017"},"n_packages":3,"n_references":7,"next":{"headline":"Integer overflow in n/a","id":"CVE-2017-7273"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["5.3.17-111.2"],"introduced":["0"],"last_affected":[],"package":"php53","purl":"pkg:rpm/suse/php53\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2017:1709-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["5.3.17-111.2"],"introduced":["0"],"last_affected":[],"package":"php53","purl":"pkg:rpm/suse/php53\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2017:1709-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["5.3.17-111.2"],"introduced":["0"],"last_affected":[],"package":"php53","purl":"pkg:rpm/suse/php53\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2017:1709-1"}],"prev":{"headline":"Yii Framework Reflected XSS","id":"CVE-2017-7271"},"products":["n/a"],"published":"2017-03-27","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can bypass port restrictions in PHP applications using fsockopen by specifying a port in the hostname argument, leading to Server-Side Request Forgery.","url":"https://insights.sbomify.com/CVE-2017-7272/"}