# CVE-2017-7297: Rancher Access Control Vulnerability

> Authenticated users can disable access control via an API call, bypassing security restrictions in Rancher server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w3x4-9854-95x8, GO-2023-1973

## What is CVE-2017-7297?

CVE-2017-7297 is a high-severity missing authorization vulnerability in n/a, published on 29 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.

## Which versions are affected by CVE-2017-7297?

9 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 1.2.0 | 1.2.4, 1.3.5, 1.4.3, 1.5.3 |
| `github.com/rancher/rancher` | Go | From 1.2.0 | 1.2.4 |
| `github.com/rancher/rancher` | Go | From 1.2.0 | 1.2.4 |
| `github.com/rancher/rancher` | Go | From 1.3.0 | 1.3.5 |
| `github.com/rancher/rancher` | Go | From 1.3.0 | 1.3.5 |
| `github.com/rancher/rancher` | Go | From 1.4.0 | 1.4.3 |
| `github.com/rancher/rancher` | Go | From 1.4.0 | 1.4.3 |
| `github.com/rancher/rancher` | Go | From 1.5.0 | 1.5.3 |
| `github.com/rancher/rancher` | Go | From 1.5.0 | 1.5.3 |

Products: Suse Rancher.

## How do I fix CVE-2017-7297?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 1.2.4, 1.3.5, 1.4.3 or 1.5.3.

## Is CVE-2017-7297 being exploited?

There is no known exploitation of CVE-2017-7297 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7297 and fix it if it is affected.

What it is: CVE-2017-7297 is a high-severity missing authorization vulnerability in n/a, published on 29 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7297 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 1.2.0; fixed in 1.2.4, 1.3.5, 1.4.3, 1.5.3
- github.com/rancher/rancher (Go): affected from 1.2.0; fixed in 1.2.4
- github.com/rancher/rancher (Go): affected from 1.2.0; fixed in 1.2.4
- github.com/rancher/rancher (Go): affected from 1.3.0; fixed in 1.3.5
- github.com/rancher/rancher (Go): affected from 1.3.0; fixed in 1.3.5
- github.com/rancher/rancher (Go): affected from 1.4.0; fixed in 1.4.3
- github.com/rancher/rancher (Go): affected from 1.4.0; fixed in 1.4.3
- github.com/rancher/rancher (Go): affected from 1.5.0; fixed in 1.5.3
- github.com/rancher/rancher (Go): affected from 1.5.0; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7297/ (Markdown: https://insights.sbomify.com/CVE-2017-7297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7297
- OSV: https://osv.dev/vulnerability/CVE-2017-7297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7297/
Summaries are generated and may contain mistakes; the official description above is the record.
