{"answers":{"affected":"2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7298 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-7298 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-7298 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Mar 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7298 and fix it if it is affected.\n\nWhat it is: CVE-2017-7298 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Mar 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-7298 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.2 up to 3.2.2; no fix listed\n- moodle/moodle (Packagist): affected from 3.2 up to 3.2.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7298/ (Markdown: https://insights.sbomify.com/CVE-2017-7298/index.md)","id":"CVE-2017-7298","markdown":"https://insights.sbomify.com/CVE-2017-7298/index.md","name":"CVE-2017-7298","record":{"aliases":["GHSA-4m6v-x9fj-847j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via SVG attributes in the course summary, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Moodle 3.2.2+, there is XSS in the Course summary filter of the \"Add a new course\" page, as demonstrated by a crafted attribute of an SVG element.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Moodle Cross-site Scripting in the Course summary filter of the Add a new course","id":"CVE-2017-7298","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-7299"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["3.2"],"last_affected":["3.2.2"],"package":"moodle/moodle","purl":null,"source":"GHSA-4m6v-x9fj-847j"},{"ecosystem":"Packagist","fixed":[],"introduced":["3.2"],"last_affected":["3.2.2"],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-4m6v-x9fj-847j"}],"prev":{"headline":"Rancher Access Control Vulnerability","id":"CVE-2017-7297"},"products":["n/a"],"published":"2017-03-29","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via SVG attributes in the course summary, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2017-7298/"}