{"answers":{"affected":"2 open source packages ship an affected version, including dweeves/magmi. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7391 exists.","fix":"Upgrade dweeves/magmi to 0.7.24 or later.","what":"CVE-2017-7391 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7391 and fix it if it is affected.\n\nWhat it is: CVE-2017-7391 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7391 exists.\n\nAffected packages and fixed versions:\n- dweeves/magmi (Packagist): affected all versions; fixed in 0.7.24\n- dweeves/magmi (Packagist): affected all versions; fixed in 0.7.24\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7391/ (Markdown: https://insights.sbomify.com/CVE-2017-7391/index.md)","id":"CVE-2017-7391","markdown":"https://insights.sbomify.com/CVE-2017-7391/index.md","name":"CVE-2017-7391","record":{"aliases":["GHSA-r8vh-cm9f-rc29"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Magmi import tool","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in a victim's browser via the Magmi import tool's time AJAX endpoint.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"magmi","vendor":"magmi_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the 'magmi-git-master/magmi/web/ajax_gettime.php' URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2017/CVE-2017-7391.yaml","stars":null,"title":"Magmi 0.7.22 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Magmi XSS Vulnerability","id":"CVE-2017-7391","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-7392"},"packages":[{"ecosystem":"Packagist","fixed":["0.7.24"],"introduced":["0"],"last_affected":[],"package":"dweeves/magmi","purl":null,"source":"GHSA-r8vh-cm9f-rc29"},{"ecosystem":"Packagist","fixed":["0.7.24"],"introduced":["0"],"last_affected":[],"package":"dweeves/magmi","purl":"pkg:composer/dweeves/magmi","source":"GHSA-r8vh-cm9f-rc29"}],"prev":{"headline":"SocialNetwork Cross-Site Scripting (XSS) vulnerability","id":"CVE-2017-7390"},"products":["n/a"],"published":"2017-04-01","related":[{"cvss_score":9.8,"headline":"Authentication bypass in MAGMI","id":"CVE-2020-5777","kev_date_added":null,"published":"2020-09-01"},{"cvss_score":9,"headline":"MAGMI plugin for Magento Unsafe File Upload","id":"CVE-2014-8770","kev_date_added":null,"published":"2014-11-13"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in MAGMI","id":"CVE-2020-5776","kev_date_added":null,"published":"2020-09-01"},{"cvss_score":5,"headline":"MAGMI plugin for Magento Server Directory Traversal","id":"CVE-2015-2067","kev_date_added":null,"published":"2015-02-24"},{"cvss_score":4.3,"headline":"MAGMI cross-site scripting (XSS)","id":"CVE-2015-2068","kev_date_added":null,"published":"2015-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in a victim's browser via the Magmi import tool's time AJAX endpoint.","url":"https://insights.sbomify.com/CVE-2017-7391/"}