# CVE-2017-7391: Magmi XSS Vulnerability

> An attacker can execute arbitrary scripts in a victim's browser via the Magmi import tool's time AJAX endpoint.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-r8vh-cm9f-rc29

## What is CVE-2017-7391?

CVE-2017-7391 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the 'magmi-git-master/magmi/web/ajax_gettime.php' URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-7391?

2 open source packages ship an affected version, including dweeves/magmi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dweeves/magmi` | Packagist | All versions | 0.7.24 |
| `dweeves/magmi` | Packagist | All versions | 0.7.24 |

Products: Magmi Project Magmi.

## How do I fix CVE-2017-7391?

Upgrade dweeves/magmi to 0.7.24 or later.

## Is CVE-2017-7391 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7391 exists.

Public exploit code:

- Magmi 0.7.22 - Cross-Site Scripting (nuclei): http/cves/2017/CVE-2017-7391.yaml

## Other vulnerabilities in n/a

- [CVE-2020-5777](https://insights.sbomify.com/CVE-2020-5777/): Authentication bypass in MAGMI (critical 9.8)
- [CVE-2014-8770](https://insights.sbomify.com/CVE-2014-8770/): MAGMI plugin for Magento Unsafe File Upload (critical 9.0)
- [CVE-2020-5776](https://insights.sbomify.com/CVE-2020-5776/): Cross-Site Request Forgery in MAGMI (high 8.8)
- [CVE-2015-2067](https://insights.sbomify.com/CVE-2015-2067/): MAGMI plugin for Magento Server Directory Traversal (medium 5.0)
- [CVE-2015-2068](https://insights.sbomify.com/CVE-2015-2068/): MAGMI cross-site scripting (XSS) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7391 and fix it if it is affected.

What it is: CVE-2017-7391 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7391 exists.

Affected packages and fixed versions:
- dweeves/magmi (Packagist): affected all versions; fixed in 0.7.24
- dweeves/magmi (Packagist): affected all versions; fixed in 0.7.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7391/ (Markdown: https://insights.sbomify.com/CVE-2017-7391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7391
- OSV: https://osv.dev/vulnerability/CVE-2017-7391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7391/
Summaries are generated and may contain mistakes; the official description above is the record.
