CVE-2017-7400 OpenStack Horizon Cross-site Scripting (XSS)
Remote authenticated administrators can execute cross-site scripting attacks via crafted federation mappings in OpenStack Horizon.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-7400?
CVE-2017-7400 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Apr 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
OpenStack Horizon 9.x through 9.1.1, 10.x through 10.0.2, and 11.0.0 allows remote authenticated administrators to conduct XSS attacks via a crafted federation mapping.
Weakness: CWE-79
Which versions are affected by CVE-2017-7400?
7 open source packages ship an affected version, including horizon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
horizon PyPI | From 10.0 | 10.0.3 |
horizon PyPI | From 10.0 | 10.0.3 |
horizon PyPI | From 11.0.0 | 11.0.1 |
horizon PyPI | From 11.0.0 | 11.0.1 |
horizon PyPI | From 9.0 | 9.1.2, 10.0.3, 11.0.1 |
horizon PyPI | From 9.0 | 9.1.2 |
1 more packages
horizon PyPI | From 9.0 | 9.1.2 |
Linux distribution packages (6)
openstack-dashboard Red Hat:openstack:10::el7 | All versions | 1:10.0.3-6.el7ost |
openstack-dashboard-theme Red Hat:openstack:10::el7 | All versions | 1:10.0.3-6.el7ost |
python-django-horizon Red Hat:openstack:10::el7 | All versions | 1:10.0.3-6.el7ost |
openstack-dashboard Red Hat:openstack:9::el7 | All versions | 1:9.0.1-13.el7ost |
openstack-dashboard-theme Red Hat:openstack:9::el7 | All versions | 1:9.0.1-13.el7ost |
python-django-horizon Red Hat:openstack:9::el7 | All versions | 1:9.0.1-13.el7ost |
Products include Openstack Horizon.
How do I fix CVE-2017-7400?
Upgrade horizon to a fixed version for your release line: 10.0.3, 11.0.1 or 9.1.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-7400 being exploited?
There is no known exploitation of CVE-2017-7400 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2017-7400, GHSA-47vp-44v9-rhgq, PYSEC-2026-821, RHSA-2017:1598, RHSA-2017:1739.