# CVE-2017-7400: OpenStack Horizon Cross-site Scripting (XSS)

> Remote authenticated administrators can execute cross-site scripting attacks via crafted federation mappings in OpenStack Horizon.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-7400, GHSA-47vp-44v9-rhgq, PYSEC-2026-821, RHSA-2017:1598, RHSA-2017:1739

## What is CVE-2017-7400?

CVE-2017-7400 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Apr 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OpenStack Horizon 9.x through 9.1.1, 10.x through 10.0.2, and 11.0.0 allows remote authenticated administrators to conduct XSS attacks via a crafted federation mapping.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-7400?

7 open source packages ship an affected version, including horizon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `horizon` | PyPI | From 10.0 | 10.0.3 |
| `horizon` | PyPI | From 10.0 | 10.0.3 |
| `horizon` | PyPI | From 11.0.0 | 11.0.1 |
| `horizon` | PyPI | From 11.0.0 | 11.0.1 |
| `horizon` | PyPI | From 9.0 | 9.1.2, 10.0.3, 11.0.1 |
| `horizon` | PyPI | From 9.0 | 9.1.2 |
| `horizon` | PyPI | From 9.0 | 9.1.2 |
| `openstack-dashboard` | Red Hat:openstack:10::el7 | All versions | 1:10.0.3-6.el7ost |
| `openstack-dashboard-theme` | Red Hat:openstack:10::el7 | All versions | 1:10.0.3-6.el7ost |
| `python-django-horizon` | Red Hat:openstack:10::el7 | All versions | 1:10.0.3-6.el7ost |
| `openstack-dashboard` | Red Hat:openstack:9::el7 | All versions | 1:9.0.1-13.el7ost |
| `openstack-dashboard-theme` | Red Hat:openstack:9::el7 | All versions | 1:9.0.1-13.el7ost |
| `python-django-horizon` | Red Hat:openstack:9::el7 | All versions | 1:9.0.1-13.el7ost |

Products: Openstack Horizon.

## How do I fix CVE-2017-7400?

Upgrade horizon to a fixed version for your release line: 10.0.3, 11.0.1 or 9.1.2.

## Is CVE-2017-7400 being exploited?

There is no known exploitation of CVE-2017-7400 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-2144](https://insights.sbomify.com/CVE-2012-2144/): OpenStack Horizon Session Fixation (medium 6.8)
- [CVE-2022-45582](https://insights.sbomify.com/CVE-2022-45582/): Horizon Web Dashboard Open Redirect vulnerability (medium 6.1)
- [CVE-2026-55748](https://insights.sbomify.com/CVE-2026-55748/): OpenStack Horizon RC file generation does not escape special characters in project names (medium 6.0)
- [CVE-2012-3540](https://insights.sbomify.com/CVE-2012-3540/): Open redirect in n/a (medium 5.8)
- [CVE-2013-4471](https://insights.sbomify.com/CVE-2013-4471/): Auth bypass in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7400 and fix it if it is affected.

What it is: CVE-2017-7400 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Apr 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7400 in the wild and no public exploit code.

Affected packages and fixed versions:
- horizon (PyPI): affected from 10.0; fixed in 10.0.3
- horizon (PyPI): affected from 10.0; fixed in 10.0.3
- horizon (PyPI): affected from 11.0.0; fixed in 11.0.1
- horizon (PyPI): affected from 11.0.0; fixed in 11.0.1
- horizon (PyPI): affected from 9.0; fixed in 9.1.2, 10.0.3, 11.0.1
- horizon (PyPI): affected from 9.0; fixed in 9.1.2
- horizon (PyPI): affected from 9.0; fixed in 9.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7400/ (Markdown: https://insights.sbomify.com/CVE-2017-7400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7400
- OSV: https://osv.dev/vulnerability/CVE-2017-7400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7400/
Summaries are generated and may contain mistakes; the official description above is the record.
