CVE-2017-7466 Ansible Arbitrary Code Execution
An attacker controlling a managed client can send malicious facts to execute arbitrary code on the Ansible server with server privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-7466?
CVE-2017-7466 is a high-severity code injection vulnerability in Redhat Openstack, published on 22 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Weakness: CWE-20
Which versions are affected by CVE-2017-7466?
3 open source packages ship an affected version, including ansible. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.2.3.0 |
ansible PyPI | All versions | 2.2.3.0 |
ansible PyPI | All versions | 2.3.0.0 |
Products include Redhat Ansible, Redhat Openstack.
How do I fix CVE-2017-7466?
Upgrade ansible to a fixed version for your release line: 2.2.3.0 or 2.3.0.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2017-7466 being exploited?
There is no known exploitation of CVE-2017-7466 in the wild and no public exploit code.
Other vulnerabilities in Redhat Openstack
Sources
Also known as CVE-2017-7469, DEBIAN-CVE-2017-7466, GHSA-3m8p-xpm6-8ww3, PYSEC-2018-40, UBUNTU-CVE-2017-7466.