{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-7466 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.2.3.0 or 2.3.0.0.","what":"CVE-2017-7466 is a high-severity code injection vulnerability in Redhat Openstack, published on 22 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7466 and fix it if it is affected.\n\nWhat it is: CVE-2017-7466 is a high-severity code injection vulnerability in Redhat Openstack, published on 22 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-7466 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.2.3.0\n- ansible (PyPI): affected all versions; fixed in 2.2.3.0\n- ansible (PyPI): affected all versions; fixed in 2.3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7466/ (Markdown: https://insights.sbomify.com/CVE-2017-7466/index.md)","id":"CVE-2017-7466","markdown":"https://insights.sbomify.com/CVE-2017-7466/index.md","name":"CVE-2017-7466","record":{"aliases":["CVE-2017-7469","DEBIAN-CVE-2017-7466","GHSA-3m8p-xpm6-8ww3","PYSEC-2018-40","UBUNTU-CVE-2017-7466"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible automation server","requires_auth":"low_privilege","summary":"An attacker controlling a managed client can send malicious facts to execute arbitrary code on the Ansible server with server privileges.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:openstack","products":["redhat:openstack"],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":8,"next":{"headline":"Memory corruption in minicom","id":"CVE-2017-7467"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.3.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-3m8p-xpm6-8ww3"},{"ecosystem":"PyPI","fixed":["2.2.3.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-3m8p-xpm6-8ww3"},{"ecosystem":"PyPI","fixed":["2.3.0.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2018-40"}],"prev":{"headline":"Code injection in jboss","id":"CVE-2017-7465"},"products":["ansible"],"published":"2018-06-22","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"An attacker controlling a managed client can send malicious facts to execute arbitrary code on the Ansible server with server privileges.","url":"https://insights.sbomify.com/CVE-2017-7466/"}