# CVE-2017-7466: Ansible Arbitrary Code Execution

> An attacker controlling a managed client can send malicious facts to execute arbitrary code on the Ansible server with server privileges.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2017-7469, DEBIAN-CVE-2017-7466, GHSA-3m8p-xpm6-8ww3, PYSEC-2018-40, UBUNTU-CVE-2017-7466

## What is CVE-2017-7466?

CVE-2017-7466 is a high-severity code injection vulnerability in Redhat Openstack, published on 22 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-7466?

3 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.2.3.0 |
| `ansible` | PyPI | All versions | 2.2.3.0 |
| `ansible` | PyPI | All versions | 2.3.0.0 |

Products: Redhat Ansible, Redhat Openstack.

## How do I fix CVE-2017-7466?

Upgrade ansible to a fixed version for your release line: 2.2.3.0 or 2.3.0.0.

## Is CVE-2017-7466 being exploited?

There is no known exploitation of CVE-2017-7466 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7466 and fix it if it is affected.

What it is: CVE-2017-7466 is a high-severity code injection vulnerability in Redhat Openstack, published on 22 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7466 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.2.3.0
- ansible (PyPI): affected all versions; fixed in 2.2.3.0
- ansible (PyPI): affected all versions; fixed in 2.3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7466/ (Markdown: https://insights.sbomify.com/CVE-2017-7466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7466
- OSV: https://osv.dev/vulnerability/CVE-2017-7466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7466/
Summaries are generated and may contain mistakes; the official description above is the record.
