{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7467 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-7467 is a high-severity memory corruption vulnerability in [UNKNOWN] minicom, published on 11 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7467 and fix it if it is affected.\n\nWhat it is: CVE-2017-7467 is a high-severity memory corruption vulnerability in [UNKNOWN] minicom, published on 11 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-7467 in the wild and no public exploit code.\n\nAffected product: [UNKNOWN] minicom. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7467/ (Markdown: https://insights.sbomify.com/CVE-2017-7467/index.md)","id":"CVE-2017-7467","markdown":"https://insights.sbomify.com/CVE-2017-7467/index.md","name":"CVE-2017-7467","record":{"aliases":["DEBIAN-CVE-2017-7467","DLA-914-1","GHSA-526f-cp8m-4xjp","MGASA-2017-0128","SUSE-SU-2017:1092-1","SUSE-SU-2017:1136-1","UBUNTU-CVE-2017-7467","openSUSE-SU-2024:11049-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Serial communication utility","requires_auth":"none","summary":"A buffer overflow in minicom allows malicious terminal devices to crash the application or execute arbitrary code.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"minicom","vendor":"minicom_project"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"},{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Desktop 12 SP2","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 12 SP1","SUSE:Linux Enterprise Server 12 SP2","SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 12 SP2","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in minicom","id":"CVE-2017-7467","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2017"},"n_packages":10,"n_references":4,"next":{"headline":"Security feature bypass in curl","id":"CVE-2017-7468"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP2","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP2","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["2.3-27.24.6.2"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2017:1136-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20Raspberry%20Pi%2012%20SP2","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["2.3-27.24.6.2"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2017:1136-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["2.7-3.1"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/suse/minicom\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2017:1092-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.7.1-2.9"],"introduced":["0"],"last_affected":[],"package":"minicom","purl":"pkg:rpm/opensuse/minicom\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11049-1"}],"prev":{"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466"},"products":["minicom"],"published":"2018-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"A buffer overflow in minicom allows malicious terminal devices to crash the application or execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2017-7467/"}