{"answers":{"affected":"4 open source packages ship an affected version, including keycloak-connect and keycloak-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7474 in the wild and no public exploit code.","fix":"Upgrade keycloak-connect to 3.1.0 or later.","what":"CVE-2017-7474 is a critical authentication bypass vulnerability in Red Hat, Inc. Keycloak Node.js adapter, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7474 and fix it if it is affected.\n\nWhat it is: CVE-2017-7474 is a critical authentication bypass vulnerability in Red Hat, Inc. Keycloak Node.js adapter, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7474 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- keycloak-connect (npm): affected from 2.5.0; fixed in 3.1.0\n- keycloak-connect (npm): affected from 2.5.0; fixed in 3.1.0\n- keycloak-js (npm): affected from 2.5.0; fixed in 3.1.0\n- keycloak-js (npm): affected from 2.5.0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7474/ (Markdown: https://insights.sbomify.com/CVE-2017-7474/index.md)","id":"CVE-2017-7474","markdown":"https://insights.sbomify.com/CVE-2017-7474/index.md","name":"CVE-2017-7474","record":{"aliases":["GHSA-mw35-24gh-f82w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Keycloak Node.js adapter","requires_auth":"none","summary":"Attackers can bypass authentication in the Keycloak Node.js adapter by exploiting improper handling of invalid tokens, gaining unauthorized access to restricted information.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"keycloak-nodejs-auth-utils","vendor":"keycloak"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-253","name":"Incorrect Check of Function Return Value"}],"description":"It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly.  An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"keycloak-connect and keycloak-js improperly handle invalid tokens","id":"CVE-2017-7474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":4,"n_references":2,"next":{"headline":"cairo is vulnerable to denial of service due to a null pointer dereference","id":"CVE-2017-7475"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["2.5.0"],"last_affected":[],"package":"keycloak-connect","purl":null,"source":"GHSA-mw35-24gh-f82w"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["2.5.0"],"last_affected":[],"package":"keycloak-connect","purl":"pkg:npm/keycloak-connect","source":"GHSA-mw35-24gh-f82w"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["2.5.0"],"last_affected":[],"package":"keycloak-js","purl":null,"source":"GHSA-mw35-24gh-f82w"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["2.5.0"],"last_affected":[],"package":"keycloak-js","purl":"pkg:npm/keycloak-js","source":"GHSA-mw35-24gh-f82w"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-7473"},"products":["Keycloak Node.js adapter"],"published":"2017-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat, Inc."]},"summary":"Attackers can bypass authentication in the Keycloak Node.js adapter by exploiting improper handling of invalid tokens, gaining unauthorized access to restricted information.","url":"https://insights.sbomify.com/CVE-2017-7474/"}