# CVE-2017-7474: keycloak-connect and keycloak-js improperly handle invalid tokens

> Attackers can bypass authentication in the Keycloak Node.js adapter by exploiting improper handling of invalid tokens, gaining unauthorized access to restricted information.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mw35-24gh-f82w

## What is CVE-2017-7474?

CVE-2017-7474 is a critical authentication bypass vulnerability in Red Hat, Inc. Keycloak Node.js adapter, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly.  An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.

Weakness: CWE-253 (Incorrect Check of Function Return Value)

## Which versions are affected by CVE-2017-7474?

4 open source packages ship an affected version, including keycloak-connect and keycloak-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keycloak-connect` | npm | From 2.5.0 | 3.1.0 |
| `keycloak-connect` | npm | From 2.5.0 | 3.1.0 |
| `keycloak-js` | npm | From 2.5.0 | 3.1.0 |
| `keycloak-js` | npm | From 2.5.0 | 3.1.0 |

Products: Keycloak Keycloak-Nodejs-Auth-Utils.

## How do I fix CVE-2017-7474?

Upgrade keycloak-connect to 3.1.0 or later.

## Is CVE-2017-7474 being exploited?

There is no known exploitation of CVE-2017-7474 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7474 and fix it if it is affected.

What it is: CVE-2017-7474 is a critical authentication bypass vulnerability in Red Hat, Inc. Keycloak Node.js adapter, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7474 in the wild and no public exploit code.

Affected packages and fixed versions:
- keycloak-connect (npm): affected from 2.5.0; fixed in 3.1.0
- keycloak-connect (npm): affected from 2.5.0; fixed in 3.1.0
- keycloak-js (npm): affected from 2.5.0; fixed in 3.1.0
- keycloak-js (npm): affected from 2.5.0; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7474/ (Markdown: https://insights.sbomify.com/CVE-2017-7474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7474
- OSV: https://osv.dev/vulnerability/CVE-2017-7474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7474/
Summaries are generated and may contain mistakes; the official description above is the record.
