# CVE-2017-7475: cairo is vulnerable to denial of service due to a null pointer dereference

> A NULL pointer dereference in Cairo allows attackers to cause a denial of service via crafted glyph rendering requests.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-7475, ECHO-36d1-db60-5570, GHSA-5v3f-73gv-x7x5, MGASA-2020-0359, UBUNTU-CVE-2017-7475

## What is CVE-2017-7475?

CVE-2017-7475 is a medium-severity vulnerability in Red Hat, Inc. Cairo, published on 19 May 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Cairo version 1.15.4 is vulnerable to a NULL pointer dereference related to the FT_Load_Glyph and FT_Render_Glyph resulting in an application crash.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2017-7475?

2 open source packages ship an affected version, including cairo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cairo` | RubyGems | From 1.15.4 | 1.15.5 |
| `cairo` | RubyGems | From 1.15.4 | 1.15.5 |

Products: Cairographics Cairo.

## How do I fix CVE-2017-7475?

Upgrade cairo to 1.15.5 or later.

## Is CVE-2017-7475 being exploited?

There is no known exploitation of CVE-2017-7475 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat, Inc. Cairo

- [CVE-2020-35492](https://insights.sbomify.com/CVE-2020-35492/): Memory corruption in cairo (high 7.8)
- [CVE-2017-9814](https://insights.sbomify.com/CVE-2017-9814/): Denial of service in n/a (high 7.5)
- [CVE-2016-3190](https://insights.sbomify.com/CVE-2016-3190/): Denial of service in n/a (high 7.5)
- [CVE-2019-6461](https://insights.sbomify.com/CVE-2019-6461/): Denial of service in n/a (medium 6.5)
- [CVE-2019-6462](https://insights.sbomify.com/CVE-2019-6462/): Denial of service in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7475 and fix it if it is affected.

What it is: CVE-2017-7475 is a medium-severity vulnerability in Red Hat, Inc. Cairo, published on 19 May 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7475 in the wild and no public exploit code.

Affected packages and fixed versions:
- cairo (RubyGems): affected from 1.15.4; fixed in 1.15.5
- cairo (RubyGems): affected from 1.15.4; fixed in 1.15.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7475/ (Markdown: https://insights.sbomify.com/CVE-2017-7475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7475
- OSV: https://osv.dev/vulnerability/CVE-2017-7475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7475/
Summaries are generated and may contain mistakes; the official description above is the record.
