{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7478 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2017-7478 is a high-severity denial of service vulnerability in openvpn, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7478 and fix it if it is affected.\n\nWhat it is: CVE-2017-7478 is a high-severity denial of service vulnerability in openvpn, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7478 exists.\n\nAffected product: openvpn. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7478/ (Markdown: https://insights.sbomify.com/CVE-2017-7478/index.md)","id":"CVE-2017-7478","markdown":"https://insights.sbomify.com/CVE-2017-7478/index.md","name":"CVE-2017-7478","record":{"aliases":["ALPINE-CVE-2017-7478","DEBIAN-CVE-2017-7478","GHSA-3wwj-66cm-595v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenVPN server","requires_auth":"none","summary":"Unauthenticated attackers can cause a denial of service on OpenVPN servers by sending large control packets.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"openvpn","vendor":"openvpn"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-617","name":"Reachable Assertion"}],"description":"OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.","ecosystems":[],"exploits":{"exploitdb":1,"first_seen":"2017-05-11","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-05-11","kind":"exploitdb","ref":"41993","stars":null,"title":"OpenVPN 2.4.0 - Denial of Service"}],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in openvpn","id":"CVE-2017-7478","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":0,"n_references":4,"next":{"headline":"Denial of service in openvpn","id":"CVE-2017-7479"},"packages":[],"prev":{"headline":"Memory corruption in Linux kernel","id":"CVE-2017-7477"},"products":["openvpn"],"published":"2017-05-15","related":[{"cvss_score":9.1,"headline":"Memory corruption in OpenVPN","id":"CVE-2025-12106","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":9.1,"headline":"Information disclosure in OpenVPN","id":"CVE-2024-5594","kev_date_added":null,"published":"2025-01-06"},{"cvss_score":9.1,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-7544","kev_date_added":null,"published":"2018-03-16"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2006-1629","kev_date_added":null,"published":"2006-04-06"},{"cvss_score":8.8,"headline":"Privilege escalation in OpenVPN","id":"CVE-2024-4877","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":7.8,"headline":"Code injection in OpenVPN-GUI","id":"CVE-2021-3606","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2018-9336","kev_date_added":null,"published":"2018-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["OpenVPN Technologies, Inc"]},"summary":"Unauthenticated attackers can cause a denial of service on OpenVPN servers by sending large control packets.","url":"https://insights.sbomify.com/CVE-2017-7478/"}