# CVE-2017-7478: Denial of service in openvpn

> Unauthenticated attackers can cause a denial of service on OpenVPN servers by sending large control packets.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2017-7478, DEBIAN-CVE-2017-7478, GHSA-3wwj-66cm-595v

## What is CVE-2017-7478?

CVE-2017-7478 is a high-severity denial of service vulnerability in openvpn, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.

Weakness: CWE-20 (Improper Input Validation), CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2017-7478?

It affects 1 product.


Products: Openvpn Openvpn.

## How do I fix CVE-2017-7478?

Upgrade to a fixed version.

## Is CVE-2017-7478 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7478 exists.

Public exploit code:

- OpenVPN 2.4.0 - Denial of Service (exploitdb)

## Other vulnerabilities in openvpn

- [CVE-2025-12106](https://insights.sbomify.com/CVE-2025-12106/): Memory corruption in OpenVPN (critical 9.1)
- [CVE-2024-5594](https://insights.sbomify.com/CVE-2024-5594/): Information disclosure in OpenVPN (critical 9.1)
- [CVE-2018-7544](https://insights.sbomify.com/CVE-2018-7544/): Cross-site request forgery in n/a (critical 9.1)
- [CVE-2006-1629](https://insights.sbomify.com/CVE-2006-1629/): Code injection in n/a (critical 9.0)
- [CVE-2024-4877](https://insights.sbomify.com/CVE-2024-4877/): Privilege escalation in OpenVPN (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7478 and fix it if it is affected.

What it is: CVE-2017-7478 is a high-severity denial of service vulnerability in openvpn, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7478 exists.

Affected product: openvpn. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7478/ (Markdown: https://insights.sbomify.com/CVE-2017-7478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7478
- OSV: https://osv.dev/vulnerability/CVE-2017-7478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7478/
Summaries are generated and may contain mistakes; the official description above is the record.
