CVE-2017-7481 Ansible fails to properly mark lookup-plugin results as unsafe
Attackers can execute arbitrary code by injecting Unicode strings into Ansible lookup plugin results processed by Jinja2.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-7481?
CVE-2017-7481 is a medium-severity code injection vulnerability in Canonical Ubuntu Linux, published on 19 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.
Weakness: CWE-20
Which versions are affected by CVE-2017-7481?
7 open source packages ship an affected version, including ansible. It affects 9 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.3.1.0, 2.4.0.0 |
ansible PyPI | All versions | 2.1.6.0 |
ansible PyPI | All versions | 2.1.6.0 |
ansible PyPI | From 2.2.0.0 | 2.2.3.0 |
ansible PyPI | From 2.2.0.0 | 2.2.3.0 |
ansible PyPI | From 2.3.0.0 | 2.3.1.0 |
1 more packages
ansible PyPI | From 2.3.0.0 | 2.3.1.0 |
Linux distribution packages (2)
ansible Red Hat:rhev_manager:4 | All versions | 0:2.3.1.0-3.el7 |
ansible-doc Red Hat:rhev_manager:4 | All versions | 0:2.3.1.0-3.el7 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Redhat Ansible Engine, Redhat Gluster Storage, Redhat Openshift Container Platform, Redhat Openstack and 3 more.
How do I fix CVE-2017-7481?
Upgrade ansible to a fixed version for your release line: 2.3.1.0, 2.4.0.0, 2.1.6.0 or 2.2.3.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2017-7481 being exploited?
There is no known exploitation of CVE-2017-7481 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2017-7481, GHSA-w578-j992-554x, PYSEC-2018-41, RHSA-2017:2524, UBUNTU-CVE-2017-7481.