# CVE-2017-7481: Ansible fails to properly mark lookup-plugin results as unsafe

> Attackers can execute arbitrary code by injecting Unicode strings into Ansible lookup plugin results processed by Jinja2.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-7481, GHSA-w578-j992-554x, PYSEC-2018-41, RHSA-2017:2524, UBUNTU-CVE-2017-7481

## What is CVE-2017-7481?

CVE-2017-7481 is a medium-severity code injection vulnerability in Canonical Ubuntu Linux, published on 19 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-7481?

7 open source packages ship an affected version, including ansible. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.3.1.0, 2.4.0.0 |
| `ansible` | PyPI | All versions | 2.1.6.0 |
| `ansible` | PyPI | All versions | 2.1.6.0 |
| `ansible` | PyPI | From 2.2.0.0 | 2.2.3.0 |
| `ansible` | PyPI | From 2.2.0.0 | 2.2.3.0 |
| `ansible` | PyPI | From 2.3.0.0 | 2.3.1.0 |
| `ansible` | PyPI | From 2.3.0.0 | 2.3.1.0 |
| `ansible` | Red Hat:rhev_manager:4 | All versions | 0:2.3.1.0-3.el7 |
| `ansible-doc` | Red Hat:rhev_manager:4 | All versions | 0:2.3.1.0-3.el7 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Redhat Ansible Engine, Redhat Gluster Storage, Redhat Openshift Container Platform, Redhat Openstack, Redhat Storage Console, Redhat Virtualization, Redhat Virtualization Manager.

## How do I fix CVE-2017-7481?

Upgrade ansible to a fixed version for your release line: 2.3.1.0, 2.4.0.0, 2.1.6.0 or 2.2.3.0.

## Is CVE-2017-7481 being exploited?

There is no known exploitation of CVE-2017-7481 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7481 and fix it if it is affected.

What it is: CVE-2017-7481 is a medium-severity code injection vulnerability in Canonical Ubuntu Linux, published on 19 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7481 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.3.1.0, 2.4.0.0
- ansible (PyPI): affected all versions; fixed in 2.1.6.0
- ansible (PyPI): affected all versions; fixed in 2.1.6.0
- ansible (PyPI): affected from 2.2.0.0; fixed in 2.2.3.0
- ansible (PyPI): affected from 2.2.0.0; fixed in 2.2.3.0
- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.1.0
- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7481/ (Markdown: https://insights.sbomify.com/CVE-2017-7481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7481
- OSV: https://osv.dev/vulnerability/CVE-2017-7481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7481/
Summaries are generated and may contain mistakes; the official description above is the record.
