CVE-2017-7489 Moodle External blog editing takeover
Authenticated users can take ownership of arbitrary blogs by editing external blog links, allowing unauthorized control over content.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7489?
CVE-2017-7489 is a medium-severity vulnerability in Moodle Moodle, published on 15 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle 2.x and 3.x, remote authenticated users can take ownership of arbitrary blogs by editing an external blog link.
Weakness: CWE-269
Which versions are affected by CVE-2017-7489?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7 | 2.7.20 |
moodle/moodle Packagist | From 2.7 | 2.7.20 |
moodle/moodle Packagist | From 3.0 | 3.0.10 |
moodle/moodle Packagist | From 3.0 | 3.0.10 |
moodle/moodle Packagist | From 3.1 | 3.1.6 |
moodle/moodle Packagist | From 3.1 | 3.1.6 |
2 more packages
moodle/moodle Packagist | From 3.2 | 3.2.3 |
moodle/moodle Packagist | From 3.2 | 3.2.3 |
Products include Moodle Moodle.
How do I fix CVE-2017-7489?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.20, 3.0.10, 3.1.6 or 3.2.3.
Is CVE-2017-7489 being exploited?
There is no known exploitation of CVE-2017-7489 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-m34m-fgh4-v7cx, UBUNTU-CVE-2017-7489.