CVE-2017-7490 Moodle Unauthorized searching of arbitrary blogs by typing full url
Attackers can search arbitrary blogs in Moodle due to a missing capability check, leading to unauthorized data disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7490?
CVE-2017-7490 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing.
Weakness: CWE-668
Which versions are affected by CVE-2017-7490?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7 | 2.7.20 |
moodle/moodle Packagist | From 2.7 | 2.7.20 |
moodle/moodle Packagist | From 3.0 | 3.0.10 |
moodle/moodle Packagist | From 3.0 | 3.0.10 |
moodle/moodle Packagist | From 3.1 | 3.1.6 |
moodle/moodle Packagist | From 3.1 | 3.1.6 |
2 more packages
moodle/moodle Packagist | From 3.2 | 3.2.3 |
moodle/moodle Packagist | From 3.2 | 3.2.3 |
Products include Moodle Moodle.
How do I fix CVE-2017-7490?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.20, 3.0.10, 3.1.6 or 3.2.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2017-7490 being exploited?
There is no known exploitation of CVE-2017-7490 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-9x63-m3cc-qf3g, UBUNTU-CVE-2017-7490.