{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7508 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-7508 is a high-severity denial of service vulnerability in OpenVPN, published on 27 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7508 and fix it if it is affected.\n\nWhat it is: CVE-2017-7508 is a high-severity denial of service vulnerability in OpenVPN, published on 27 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7508 in the wild and no public exploit code.\n\nAffected product: OpenVPN. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7508/ (Markdown: https://insights.sbomify.com/CVE-2017-7508/index.md)","id":"CVE-2017-7508","markdown":"https://insights.sbomify.com/CVE-2017-7508/index.md","name":"CVE-2017-7508","record":{"aliases":["DEBIAN-CVE-2017-7508","GHSA-q55c-22v4-x379","SUSE-SU-2017:1642-1","UBUNTU-CVE-2017-7508"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenVPN server","requires_auth":"none","summary":"Remote attackers can cause a denial of service in OpenVPN by sending malformed IPv6 packets, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"openvpn","vendor":"openvpn"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote denial-of-service when receiving malformed IPv6 packet.","ecosystems":["SUSE:Linux Enterprise Point of Sale 11 SP3","SUSE:Linux Enterprise Server 11 SP3-LTSS","SUSE:Linux Enterprise Server 11 SP3-TERADATA","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in OpenVPN","id":"CVE-2017-7508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":5,"n_references":4,"next":{"headline":"Denial of service in Certificate System","id":"CVE-2017-7509"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Point of Sale 11 SP3","fixed":["2.0.9-143.46.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Point%20of%20Sale%2011%20SP3","source":"SUSE-SU-2017:1642-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP3-LTSS","fixed":["2.0.9-143.46.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP3-LTSS","source":"SUSE-SU-2017:1642-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP3-TERADATA","fixed":["2.0.9-143.46.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP3-TERADATA","source":"SUSE-SU-2017:1642-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["2.0.9-143.46.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2017:1642-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["2.0.9-143.46.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2017:1642-1"}],"prev":{"headline":"Null dereference in gnutls","id":"CVE-2017-7507"},"products":["OpenVPN"],"published":"2017-06-27","related":[{"cvss_score":9.1,"headline":"Memory corruption in OpenVPN","id":"CVE-2025-12106","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":9.1,"headline":"Information disclosure in OpenVPN","id":"CVE-2024-5594","kev_date_added":null,"published":"2025-01-06"},{"cvss_score":9.1,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-7544","kev_date_added":null,"published":"2018-03-16"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2006-1629","kev_date_added":null,"published":"2006-04-06"},{"cvss_score":8.8,"headline":"Privilege escalation in OpenVPN","id":"CVE-2024-4877","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":7.8,"headline":"Code injection in OpenVPN-GUI","id":"CVE-2021-3606","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2018-9336","kev_date_added":null,"published":"2018-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["OpenVPN Technologies, Inc"]},"summary":"Remote attackers can cause a denial of service in OpenVPN by sending malformed IPv6 packets, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2017-7508/"}