{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7509 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-7509 is a low-severity denial of service vulnerability in Red Hat Certificate System, published on 26 Jul 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-7509 and fix it if it is affected.\n\nWhat it is: CVE-2017-7509 is a low-severity denial of service vulnerability in Red Hat Certificate System, published on 26 Jul 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-7509 in the wild and no public exploit code.\n\nAffected product: Red Hat Certificate System. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7509/ (Markdown: https://insights.sbomify.com/CVE-2017-7509/index.md)","id":"CVE-2017-7509","markdown":"https://insights.sbomify.com/CVE-2017-7509/index.md","name":"CVE-2017-7509","record":{"aliases":["GHSA-2v3w-p5pg-rgxq","RHSA-2017:2560"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Red Hat Certificate System","requires_auth":"low_privilege","summary":"Attackers can cause a denial of service in Red Hat Certificate System by submitting certificates with missing certreq fields, triggering an assertion error.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"certificate_system","vendor":"redhat"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.","ecosystems":["Red Hat:certificate_system:8::el5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Certificate System","id":"CVE-2017-7509","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":9,"n_references":3,"next":{"headline":"Information disclosure in RHV","id":"CVE-2017-7510"},"packages":[{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.9-2.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-ca","purl":"pkg:rpm/redhat/pki-ca","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.20-1.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-common","purl":"pkg:rpm/redhat/pki-common","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.20-1.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-common-javadoc","purl":"pkg:rpm/redhat/pki-common-javadoc","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.7-2.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-kra","purl":"pkg:rpm/redhat/pki-kra","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.2-3.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-silent","purl":"pkg:rpm/redhat/pki-silent","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.30-1.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-tps","purl":"pkg:rpm/redhat/pki-tps","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.3-2.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-util","purl":"pkg:rpm/redhat/pki-util","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.3-2.el5pki"],"introduced":["0"],"last_affected":[],"package":"pki-util-javadoc","purl":"pkg:rpm/redhat/pki-util-javadoc","source":"RHSA-2017:2560"},{"ecosystem":"Red Hat:certificate_system:8::el5","fixed":["0:8.1.1-2.el5pki"],"introduced":["0"],"last_affected":[],"package":"redhat-pki-ca-ui","purl":"pkg:rpm/redhat/redhat-pki-ca-ui","source":"RHSA-2017:2560"}],"prev":{"headline":"Denial of service in OpenVPN","id":"CVE-2017-7508"},"products":["Certificate System"],"published":"2018-07-26","related":[{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2013-1886","kev_date_added":null,"published":"2014-01-24"},{"cvss_score":6.5,"headline":"Missing authorization in n/a","id":"CVE-2009-0588","kev_date_added":null,"published":"2009-05-27"},{"cvss_score":5.8,"headline":"Missing authorization in n/a","id":"CVE-2010-3868","kev_date_added":null,"published":"2010-11-17"},{"cvss_score":5.5,"headline":"Missing authorization in n/a","id":"CVE-2012-3367","kev_date_added":null,"published":"2012-08-13"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2013-1885","kev_date_added":null,"published":"2014-01-24"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2012-4543","kev_date_added":null,"published":"2013-01-04"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2662","kev_date_added":null,"published":"2012-08-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat"]},"summary":"Attackers can cause a denial of service in Red Hat Certificate System by submitting certificates with missing certreq fields, triggering an assertion error.","url":"https://insights.sbomify.com/CVE-2017-7509/"}