{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7524 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-7524 is a high-severity vulnerability in tpm2-tools, published on 27 Jun 2017."},"fix_prompt":"Check this codebase for CVE-2017-7524 and fix it if it is affected.\n\nWhat it is: CVE-2017-7524 is a high-severity vulnerability in tpm2-tools, published on 27 Jun 2017. \nExploitation: There is no known exploitation of CVE-2017-7524 in the wild and no public exploit code.\n\nAffected product: tpm2-tools. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7524/ (Markdown: https://insights.sbomify.com/CVE-2017-7524/index.md)","id":"CVE-2017-7524","markdown":"https://insights.sbomify.com/CVE-2017-7524/index.md","name":"CVE-2017-7524","record":{"aliases":["DEBIAN-CVE-2017-7524","GHSA-62m4-8mv5-x4gc"],"analysis":null,"analysis_generated_by":null,"assigner":"redhat","cpe":[{"product":"tpm2.0-tools","vendor":"tpm2-tools_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.","id":"CVE-2017-7524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2017"},"n_packages":0,"n_references":1,"next":{"headline":"jackson-databind is vulnerable to a deserialization flaw","id":"CVE-2017-7525"},"packages":[],"prev":{"headline":"Memory corruption in cygwin","id":"CVE-2017-7523"},"products":["tpm2-tools"],"published":"2017-06-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["TPM 2.0 Tools"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2017-7524/"}