CVE-2017-7532 Moodle Improper Privilege Management
Course creators in Moodle can modify system default settings, leading to privilege escalation and unauthorized configuration changes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7532?
CVE-2017-7532 is a medium-severity vulnerability in Moodle Moodle, published on 17 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle 3.x, course creators are able to change system default settings for courses.
Weakness: CWE-269
Which versions are affected by CVE-2017-7532?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.7 |
moodle/moodle Packagist | All versions | 3.1.7 |
moodle/moodle Packagist | From 3.2.0 | 3.2.4 |
moodle/moodle Packagist | From 3.2.0 | 3.2.4 |
moodle/moodle Packagist | From 3.3.0 | 3.3.1 |
moodle/moodle Packagist | From 3.3.0 | 3.3.1 |
Products include Moodle Moodle.
How do I fix CVE-2017-7532?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.7, 3.2.4 or 3.3.1.
Is CVE-2017-7532 being exploited?
There is no known exploitation of CVE-2017-7532 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-jjhx-5jff-rc8m, UBUNTU-CVE-2017-7532.