# CVE-2017-7536: Privilege Escalation in Hibernate Validator

> Attackers can escalate privileges and read private member values by exploiting reflective permission checks in Hibernate Validator when specific security manager permissions are granted.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-7536, GHSA-xxgp-pcfc-3vgc

## What is CVE-2017-7536?

CVE-2017-7536 is a high-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Hibernate Validator 5.2.x before 5.2.5 final, 5.3.x, and 5.4.x, it was found that when the security manager's reflective permissions, which allows it to access the private members of the class, are granted to Hibernate Validator, a potential privilege escalation can occur. By allowing the calling code to access those private members without the permission an attacker may be able to validate an invalid instance and access the private member value via ConstraintViolation#getInvalidValue().

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code), CWE-592 (DEPRECATED: Authentication Bypass Issues)

## Which versions are affected by CVE-2017-7536?

6 open source packages ship an affected version, including org.hibernate:hibernate-validator. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.hibernate:hibernate-validator` | Maven | From 5.2.0 | 5.2.5.Final |
| `org.hibernate:hibernate-validator` | Maven | From 5.2.0 | 5.2.5.Final |
| `org.hibernate:hibernate-validator` | Maven | From 5.3.0 | 5.3.6.Final |
| `org.hibernate:hibernate-validator` | Maven | From 5.3.0 | 5.3.6.Final |
| `org.hibernate:hibernate-validator` | Maven | From 5.4.0 | 5.4.2.Final |
| `org.hibernate:hibernate-validator` | Maven | From 5.4.0 | 5.4.2.Final |

Products: Redhat Hibernate Validator, Redhat Jboss Enterprise Application Platform, Redhat Satellite, Redhat Satellite Capsule, Redhat Virtualization, Redhat Virtualization Host.

## How do I fix CVE-2017-7536?

Upgrade org.hibernate:hibernate-validator to a fixed version for your release line: 5.2.5.Final, 5.3.6.Final or 5.4.2.Final.

## Is CVE-2017-7536 being exploited?

There is no known exploitation of CVE-2017-7536 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2025-35036](https://insights.sbomify.com/CVE-2025-35036/): hibernate-validator insecure default Expression Language interpolation (medium 6.9)
- [CVE-2014-3558](https://insights.sbomify.com/CVE-2014-3558/): Improper Authentication in Hibernate Validator (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7536 and fix it if it is affected.

What it is: CVE-2017-7536 is a high-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7536 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.hibernate:hibernate-validator (Maven): affected from 5.2.0; fixed in 5.2.5.Final
- org.hibernate:hibernate-validator (Maven): affected from 5.2.0; fixed in 5.2.5.Final
- org.hibernate:hibernate-validator (Maven): affected from 5.3.0; fixed in 5.3.6.Final
- org.hibernate:hibernate-validator (Maven): affected from 5.3.0; fixed in 5.3.6.Final
- org.hibernate:hibernate-validator (Maven): affected from 5.4.0; fixed in 5.4.2.Final
- org.hibernate:hibernate-validator (Maven): affected from 5.4.0; fixed in 5.4.2.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7536/ (Markdown: https://insights.sbomify.com/CVE-2017-7536/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7536
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7536
- OSV: https://osv.dev/vulnerability/CVE-2017-7536

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7536/
Summaries are generated and may contain mistakes; the official description above is the record.
