{"answers":{"affected":"2 open source packages ship an affected version, including safemode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7540 in the wild and no public exploit code.","fix":"Upgrade safemode to 1.3.2 or later.","what":"CVE-2017-7540 is a critical vulnerability in Red Hat, Inc. rubygem-safemode, published on 21 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7540 and fix it if it is affected.\n\nWhat it is: CVE-2017-7540 is a critical vulnerability in Red Hat, Inc. rubygem-safemode, published on 21 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7540 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- safemode (RubyGems): affected all versions; fixed in 1.3.2\n- safemode (RubyGems): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7540/ (Markdown: https://insights.sbomify.com/CVE-2017-7540/index.md)","id":"CVE-2017-7540","markdown":"https://insights.sbomify.com/CVE-2017-7540/index.md","name":"CVE-2017-7540","record":{"aliases":["GHSA-5vx5-9q73-wgp4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby safemode gem","requires_auth":"none","summary":"Attackers can bypass Ruby safe mode restrictions to delete unauthorized objects or escalate privileges in applications using the safemode gem.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"safemode","vendor":"safemode_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Safemode Gem Has Incomplete List of Disallowed Inputs","id":"CVE-2017-7540","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in Linux kernel before 4.12.3","id":"CVE-2017-7541"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"safemode","purl":null,"source":"GHSA-5vx5-9q73-wgp4"},{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"safemode","purl":"pkg:gem/safemode","source":"GHSA-5vx5-9q73-wgp4"}],"prev":{"headline":"Denial of service in Qemu","id":"CVE-2017-7539"},"products":["rubygem-safemode"],"published":"2017-07-21","related":[{"cvss_score":8.1,"headline":"safemode gem allows context-dependent attackers to obtain sensitive information via the inspect method","id":"CVE-2016-3693","kev_date_added":null,"published":"2016-05-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat, Inc."]},"summary":"Attackers can bypass Ruby safe mode restrictions to delete unauthorized objects or escalate privileges in applications using the safemode gem.","url":"https://insights.sbomify.com/CVE-2017-7540/"}