# CVE-2017-7540: Safemode Gem Has Incomplete List of Disallowed Inputs

> Attackers can bypass Ruby safe mode restrictions to delete unauthorized objects or escalate privileges in applications using the safemode gem.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5vx5-9q73-wgp4

## What is CVE-2017-7540?

CVE-2017-7540 is a critical vulnerability in Red Hat, Inc. rubygem-safemode, published on 21 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2017-7540?

2 open source packages ship an affected version, including safemode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `safemode` | RubyGems | All versions | 1.3.2 |
| `safemode` | RubyGems | All versions | 1.3.2 |

Products: Safemode Project Safemode.

## How do I fix CVE-2017-7540?

Upgrade safemode to 1.3.2 or later.

## Is CVE-2017-7540 being exploited?

There is no known exploitation of CVE-2017-7540 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat, Inc. rubygem-safemode

- [CVE-2016-3693](https://insights.sbomify.com/CVE-2016-3693/): safemode gem allows context-dependent attackers to obtain sensitive information via the inspect method (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7540 and fix it if it is affected.

What it is: CVE-2017-7540 is a critical vulnerability in Red Hat, Inc. rubygem-safemode, published on 21 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7540 in the wild and no public exploit code.

Affected packages and fixed versions:
- safemode (RubyGems): affected all versions; fixed in 1.3.2
- safemode (RubyGems): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7540/ (Markdown: https://insights.sbomify.com/CVE-2017-7540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7540
- OSV: https://osv.dev/vulnerability/CVE-2017-7540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7540/
Summaries are generated and may contain mistakes; the official description above is the record.
