CVE-2017-7550 Ansible Insertion of Sensitive Information into Log File vulnerability

Critical 9.8 Published Updated

Remote attackers can expose sensitive information from remote host logs via the Ansible jenkins_plugin module due to improper parameter handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-7550?

CVE-2017-7550 is a critical vulnerability in Redhat Enterprise Linux Server, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

Weakness: CWE-532

Which versions are affected by CVE-2017-7550?

5 open source packages ship an affected version, including ansible. It affects 2 products.

PackageAffectedFixed in
ansible PyPIFrom 2.3.0.02.3.3.0, 2.4.1.0
ansible PyPIFrom 2.3.0.02.3.3.0
ansible PyPIFrom 2.3.0.02.3.3.0
ansible PyPIFrom 2.4.0.02.4.1.0
ansible PyPIFrom 2.4.0.02.4.1.0
Linux distribution packages (3)
ansible Red Hat:rhel_extras_other:7All versions0:2.4.0.0-5.el7
ansible-doc Red Hat:rhel_extras_other:7All versions0:2.4.0.0-5.el7
ansible SUSE:OpenStack Cloud 7All versions2.2.3.0-9.1

Products include Redhat Ansible, Redhat Enterprise Linux Server.

How do I fix CVE-2017-7550?

Upgrade ansible to a fixed version for your release line: 2.3.3.0 or 2.4.1.0.

Is CVE-2017-7550 being exploited?

There is no known exploitation of CVE-2017-7550 in the wild and no public exploit code.

All Redhat Enterprise Linux Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2017-7550, GHSA-588w-w6mv-3cw5, MGASA-2017-0399, PYSEC-2017-4, RHSA-2017:2966, SUSE-SU-2018:0605-1.

Is CVE-2017-7550 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free