{"answers":{"affected":"5 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-7550 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.3.3.0 or 2.4.1.0.","what":"CVE-2017-7550 is a critical vulnerability in Redhat Enterprise Linux Server, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7550 and fix it if it is affected.\n\nWhat it is: CVE-2017-7550 is a critical vulnerability in Redhat Enterprise Linux Server, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7550 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.3.0, 2.4.1.0\n- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.3.0\n- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.3.0\n- ansible (PyPI): affected from 2.4.0.0; fixed in 2.4.1.0\n- ansible (PyPI): affected from 2.4.0.0; fixed in 2.4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7550/ (Markdown: https://insights.sbomify.com/CVE-2017-7550/index.md)","id":"CVE-2017-7550","markdown":"https://insights.sbomify.com/CVE-2017-7550/index.md","name":"CVE-2017-7550","record":{"aliases":["DEBIAN-CVE-2017-7550","GHSA-588w-w6mv-3cw5","MGASA-2017-0399","PYSEC-2017-4","RHSA-2017:2966","SUSE-SU-2018:0605-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"none","summary":"Remote attackers can expose sensitive information from remote host logs via the Ansible jenkins_plugin module due to improper parameter handling.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the \"params\" argument, and noting this in the module documentation.","ecosystems":["PyPI","Red Hat:rhel_extras_other:7","SUSE:OpenStack Cloud 7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:enterprise_linux_server","products":["redhat:enterprise_linux_server"],"type":"information_disclosure","year":"2017"},"n_packages":8,"n_references":3,"next":{"headline":"Information disclosure in 389-ds-base","id":"CVE-2017-7551"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.3.0","2.4.1.0"],"introduced":["2.3.0.0","2.4.0.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2017-4"},{"ecosystem":"PyPI","fixed":["2.3.3.0"],"introduced":["2.3.0.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-588w-w6mv-3cw5"},{"ecosystem":"PyPI","fixed":["2.3.3.0"],"introduced":["2.3.0.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-588w-w6mv-3cw5"},{"ecosystem":"PyPI","fixed":["2.4.1.0"],"introduced":["2.4.0.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-588w-w6mv-3cw5"},{"ecosystem":"PyPI","fixed":["2.4.1.0"],"introduced":["2.4.0.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-588w-w6mv-3cw5"},{"ecosystem":"Red Hat:rhel_extras_other:7","fixed":["0:2.4.0.0-5.el7"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:rpm/redhat/ansible","source":"RHSA-2017:2966"},{"ecosystem":"Red Hat:rhel_extras_other:7","fixed":["0:2.4.0.0-5.el7"],"introduced":["0"],"last_affected":[],"package":"ansible-doc","purl":"pkg:rpm/redhat/ansible-doc","source":"RHSA-2017:2966"},{"ecosystem":"SUSE:OpenStack Cloud 7","fixed":["2.2.3.0-9.1"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:rpm/suse/ansible\u0026distro=SUSE%20OpenStack%20Cloud%207","source":"SUSE-SU-2018:0605-1"}],"prev":{"headline":"instack-undercloud vulnerable to symlink attack on tmp files","id":"CVE-2017-7549"},"products":["ansible"],"published":"2017-11-21","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat, Inc."]},"summary":"Remote attackers can expose sensitive information from remote host logs via the Ansible jenkins_plugin module due to improper parameter handling.","url":"https://insights.sbomify.com/CVE-2017-7550/"}