# CVE-2017-7550: Ansible Insertion of Sensitive Information into Log File vulnerability

> Remote attackers can expose sensitive information from remote host logs via the Ansible jenkins_plugin module due to improper parameter handling.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-7550, GHSA-588w-w6mv-3cw5, MGASA-2017-0399, PYSEC-2017-4, RHSA-2017:2966, SUSE-SU-2018:0605-1

## What is CVE-2017-7550?

CVE-2017-7550 is a critical vulnerability in Redhat Enterprise Linux Server, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2017-7550?

5 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.3.0.0 | 2.3.3.0, 2.4.1.0 |
| `ansible` | PyPI | From 2.3.0.0 | 2.3.3.0 |
| `ansible` | PyPI | From 2.3.0.0 | 2.3.3.0 |
| `ansible` | PyPI | From 2.4.0.0 | 2.4.1.0 |
| `ansible` | PyPI | From 2.4.0.0 | 2.4.1.0 |
| `ansible` | Red Hat:rhel_extras_other:7 | All versions | 0:2.4.0.0-5.el7 |
| `ansible-doc` | Red Hat:rhel_extras_other:7 | All versions | 0:2.4.0.0-5.el7 |
| `ansible` | SUSE:OpenStack Cloud 7 | All versions | 2.2.3.0-9.1 |

Products: Redhat Ansible, Redhat Enterprise Linux Server.

## How do I fix CVE-2017-7550?

Upgrade ansible to a fixed version for your release line: 2.3.3.0 or 2.4.1.0.

## Is CVE-2017-7550 being exploited?

There is no known exploitation of CVE-2017-7550 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux Server

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)
- [CVE-2017-7466](https://insights.sbomify.com/CVE-2017-7466/): Ansible Arbitrary Code Execution (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7550 and fix it if it is affected.

What it is: CVE-2017-7550 is a critical vulnerability in Redhat Enterprise Linux Server, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7550 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.3.0, 2.4.1.0
- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.3.0
- ansible (PyPI): affected from 2.3.0.0; fixed in 2.3.3.0
- ansible (PyPI): affected from 2.4.0.0; fixed in 2.4.1.0
- ansible (PyPI): affected from 2.4.0.0; fixed in 2.4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7550/ (Markdown: https://insights.sbomify.com/CVE-2017-7550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7550
- OSV: https://osv.dev/vulnerability/CVE-2017-7550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7550/
Summaries are generated and may contain mistakes; the official description above is the record.
