CVE-2017-7559 Undertow vulnerable to Request Smuggling

Medium 6.1 Published Updated

Attackers can inject data into HTTP responses via invalid characters, enabling XSS, cache poisoning, or information disclosure in Undertow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-7559?

CVE-2017-7559 is a medium-severity cross-site scripting vulnerability in Red Hat, Inc. undertow, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

Weakness: CWE-444

Which versions are affected by CVE-2017-7559?

6 open source packages ship an affected version, including io.undertow:undertow-core. It affects 1 product.

PackageAffectedFixed in
io.undertow:undertow-core MavenFrom 1.3.01.3.31.Final
io.undertow:undertow-core MavenFrom 1.3.01.3.31.Final
io.undertow:undertow-core MavenFrom 1.4.01.4.17.Final
io.undertow:undertow-core MavenFrom 1.4.01.4.17.Final
io.undertow:undertow-core MavenFrom 2.0.0.Alpha12.0.0.Alpha2
io.undertow:undertow-core MavenFrom 2.0.0.Alpha12.0.0.Alpha2

Products include Redhat Undertow.

How do I fix CVE-2017-7559?

Upgrade io.undertow:undertow-core to a fixed version for your release line: 1.3.31.Final, 1.4.17.Final or 2.0.0.Alpha2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-7559 being exploited?

There is no known exploitation of CVE-2017-7559 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2017-7559, GHSA-rj76-h87p-r3wf, UBUNTU-CVE-2017-7559.

Is CVE-2017-7559 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free