# CVE-2017-7559: Undertow vulnerable to Request Smuggling

> Attackers can inject data into HTTP responses via invalid characters, enabling XSS, cache poisoning, or information disclosure in Undertow.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-7559, GHSA-rj76-h87p-r3wf, UBUNTU-CVE-2017-7559

## What is CVE-2017-7559?

CVE-2017-7559 is a medium-severity cross-site scripting vulnerability in Red Hat, Inc. undertow, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2017-7559?

6 open source packages ship an affected version, including io.undertow:undertow-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.undertow:undertow-core` | Maven | From 1.3.0 | 1.3.31.Final |
| `io.undertow:undertow-core` | Maven | From 1.3.0 | 1.3.31.Final |
| `io.undertow:undertow-core` | Maven | From 1.4.0 | 1.4.17.Final |
| `io.undertow:undertow-core` | Maven | From 1.4.0 | 1.4.17.Final |
| `io.undertow:undertow-core` | Maven | From 2.0.0.Alpha1 | 2.0.0.Alpha2 |
| `io.undertow:undertow-core` | Maven | From 2.0.0.Alpha1 | 2.0.0.Alpha2 |

Products: Redhat Undertow.

## How do I fix CVE-2017-7559?

Upgrade io.undertow:undertow-core to a fixed version for your release line: 1.3.31.Final, 1.4.17.Final or 2.0.0.Alpha2.

## Is CVE-2017-7559 being exploited?

There is no known exploitation of CVE-2017-7559 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat, Inc. undertow

- [CVE-2020-1745](https://insights.sbomify.com/CVE-2020-1745/): Improper Authorization in Undertoe (high 8.6)
- [CVE-2018-1114](https://insights.sbomify.com/CVE-2018-1114/): Uncontrolled Resource Consumption in Undertow (medium 6.5)
- [CVE-2024-1459](https://insights.sbomify.com/CVE-2024-1459/): Undertow: directory traversal vulnerability (medium 5.3)
- [CVE-2014-7816](https://insights.sbomify.com/CVE-2014-7816/): Improper Limitation of a Pathname to a Restricted Directory in JBoss Undertow (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7559 and fix it if it is affected.

What it is: CVE-2017-7559 is a medium-severity cross-site scripting vulnerability in Red Hat, Inc. undertow, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7559 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.undertow:undertow-core (Maven): affected from 1.3.0; fixed in 1.3.31.Final
- io.undertow:undertow-core (Maven): affected from 1.3.0; fixed in 1.3.31.Final
- io.undertow:undertow-core (Maven): affected from 1.4.0; fixed in 1.4.17.Final
- io.undertow:undertow-core (Maven): affected from 1.4.0; fixed in 1.4.17.Final
- io.undertow:undertow-core (Maven): affected from 2.0.0.Alpha1; fixed in 2.0.0.Alpha2
- io.undertow:undertow-core (Maven): affected from 2.0.0.Alpha1; fixed in 2.0.0.Alpha2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7559/ (Markdown: https://insights.sbomify.com/CVE-2017-7559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7559
- OSV: https://osv.dev/vulnerability/CVE-2017-7559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7559/
Summaries are generated and may contain mistakes; the official description above is the record.
