# CVE-2017-7561: Inconsistent Interpretation of HTTP Requests in Red Hat JBoss EAP

> Attackers can poison server-side caches or bypass CORS restrictions in JAX-RS, potentially exposing sensitive data or bypassing security controls.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2017
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-7561, GHSA-57q5-x8jf-g7h8, UBUNTU-CVE-2017-7561

## What is CVE-2017-7561?

CVE-2017-7561 is a high-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 13 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Red Hat JBoss EAP version 3.0.7 through before 4.0.0.Beta1 is vulnerable to a server-side cache poisoning or CORS requests in the JAX-RS component resulting in a moderate impact.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2017-7561?

4 open source packages ship an affected version, including org.jboss.resteasy:resteasy-jaxrs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.resteasy:resteasy-jaxrs` | Maven | From 3.0.7.Final | 3.0.25.Final |
| `org.jboss.resteasy:resteasy-jaxrs` | Maven | From 3.0.7.Final | 3.0.25.Final |
| `org.jboss.resteasy:resteasy-jaxrs` | Maven | From 3.1.4.Final | 3.5.0.CR1 |
| `org.jboss.resteasy:resteasy-jaxrs` | Maven | From 3.1.4.Final | 3.5.0.CR1 |

Products: Redhat Jboss Enterprise Application Platform.

## How do I fix CVE-2017-7561?

Upgrade org.jboss.resteasy:resteasy-jaxrs to a fixed version for your release line: 3.0.25.Final or 3.5.0.CR1.

## Is CVE-2017-7561 being exploited?

There is no known exploitation of CVE-2017-7561 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2017-12149](https://insights.sbomify.com/CVE-2017-12149/): Red Hat JBoss Application Server Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2010-1428](https://insights.sbomify.com/CVE-2010-1428/): Red Hat JBoss Information Disclosure (medium 5.9, exploited in the wild)
- [CVE-2010-0738](https://insights.sbomify.com/CVE-2010-0738/): Red Hat JBoss Authentication Bypass (low 3.7, exploited in the wild)
- [CVE-2016-3690](https://insights.sbomify.com/CVE-2016-3690/): Deserialization in n/a (critical 9.8)
- [CVE-2017-7504](https://insights.sbomify.com/CVE-2017-7504/): Deserialization in JBoss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7561 and fix it if it is affected.

What it is: CVE-2017-7561 is a high-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 13 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7561 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.resteasy:resteasy-jaxrs (Maven): affected from 3.0.7.Final; fixed in 3.0.25.Final
- org.jboss.resteasy:resteasy-jaxrs (Maven): affected from 3.0.7.Final; fixed in 3.0.25.Final
- org.jboss.resteasy:resteasy-jaxrs (Maven): affected from 3.1.4.Final; fixed in 3.5.0.CR1
- org.jboss.resteasy:resteasy-jaxrs (Maven): affected from 3.1.4.Final; fixed in 3.5.0.CR1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7561/ (Markdown: https://insights.sbomify.com/CVE-2017-7561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7561
- OSV: https://osv.dev/vulnerability/CVE-2017-7561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7561/
Summaries are generated and may contain mistakes; the official description above is the record.
