{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2017-7562 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-7562 is a medium-severity authentication bypass vulnerability in Mit Kerberos 5, published on 26 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7562 and fix it if it is affected.\n\nWhat it is: CVE-2017-7562 is a medium-severity authentication bypass vulnerability in Mit Kerberos 5, published on 26 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7562 in the wild and no public exploit code.\n\nAffected product: Mit Kerberos 5. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7562/ (Markdown: https://insights.sbomify.com/CVE-2017-7562/index.md)","id":"CVE-2017-7562","markdown":"https://insights.sbomify.com/CVE-2017-7562/index.md","name":"CVE-2017-7562","record":{"aliases":["GHSA-vg8p-42hp-9g25","SUSE-SU-2018:1425-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Kerberos authentication","requires_auth":"low_privilege","summary":"Remote attackers can impersonate arbitrary principals via a certificate validation flaw in the Kerberos KDC certauth interface.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"kerberos_5","vendor":"mit"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"An authentication bypass flaw was found in the way krb5's certauth interface before 1.16.1 handled the validation of client certificates. A remote attacker able to communicate with the KDC could potentially use this flaw to impersonate arbitrary principals under rare and erroneous circumstances.","ecosystems":["SUSE:Linux Enterprise Server 12 SP1-LTSS","SUSE:Linux Enterprise Server 12-LTSS","SUSE:Linux Enterprise Server for SAP Applications 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth bypass in krb5","id":"CVE-2017-7562","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"mit:kerberos_5","products":["mit:kerberos_5","redhat:enterprise_linux","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"auth_bypass","year":"2017"},"n_packages":3,"n_references":7,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2017-7563"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1-LTSS","fixed":["1.12.1-38.5.3"],"introduced":["0"],"last_affected":[],"package":"krb5","purl":"pkg:rpm/suse/krb5\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1-LTSS","source":"SUSE-SU-2018:1425-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12-LTSS","fixed":["1.12.1-38.5.3"],"introduced":["0"],"last_affected":[],"package":"krb5","purl":"pkg:rpm/suse/krb5\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012-LTSS","source":"SUSE-SU-2018:1425-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["1.12.1-38.5.3"],"introduced":["0"],"last_affected":[],"package":"krb5","purl":"pkg:rpm/suse/krb5\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2018:1425-1"}],"prev":{"headline":"Inconsistent Interpretation of HTTP Requests in Red Hat JBoss EAP","id":"CVE-2017-7561"},"products":["krb5"],"published":"2018-07-26","related":[{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2011-0285","kev_date_added":null,"published":"2011-04-15"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-0947","kev_date_added":null,"published":"2008-03-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2007-5902","kev_date_added":null,"published":"2007-12-06"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2007-4743","kev_date_added":null,"published":"2007-09-06"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2007-3999","kev_date_added":null,"published":"2007-09-05"},{"cvss_score":10,"headline":"Missing authorization in n/a","id":"CVE-2000-0514","kev_date_added":null,"published":"2000-10-13"},{"cvss_score":9.8,"headline":"Memory corruption in krb5 1.5","id":"CVE-2017-15088","kev_date_added":null,"published":"2017-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["MIT"]},"summary":"Remote attackers can impersonate arbitrary principals via a certificate validation flaw in the Kerberos KDC certauth interface.","url":"https://insights.sbomify.com/CVE-2017-7562/"}