# CVE-2017-7615: MantisBT allows arbitrary password reset

> Attackers can bypass authentication and gain admin access by submitting an empty confirmation hash during password reset.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-252r-f55f-ff34

## What is CVE-2017-7615?

CVE-2017-7615 is a high-severity authentication bypass vulnerability in Mantisbt Mantisbt, published on 16 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MantisBT through 2.3.0 allows arbitrary password reset and unauthenticated admin access via an empty confirm_hash value to verify.php.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2017-7615?

6 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 1.3.0-rc.2 | 1.3.10 |
| `mantisbt/mantisbt` | Packagist | From 1.3.0-rc.2 | 1.3.10 |
| `mantisbt/mantisbt` | Packagist | From 2.0.0 | 2.2.4 |
| `mantisbt/mantisbt` | Packagist | From 2.0.0 | 2.2.4 |
| `mantisbt/mantisbt` | Packagist | From 2.3.0 | 2.3.1 |
| `mantisbt/mantisbt` | Packagist | From 2.3.0 | 2.3.1 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2017-7615?

Upgrade mantisbt/mantisbt to a fixed version for your release line: 1.3.10, 2.2.4 or 2.3.1.

## Is CVE-2017-7615 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7615 exists.

Public exploit code:

- Mantis Bug Tracker 1.3.0/2.3.0 - Password Reset (exploitdb)
- MantisBT password reset (metasploit)
- Mantis Bug Tracker 2.3.0 - Remote Code Execution (Unauthenticated) (exploitdb)
- MantisBT <=2.30 - Arbitrary Password Reset/Admin Access (nuclei): http/cves/2017/CVE-2017-7615.yaml

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)
- [CVE-2026-33548](https://insights.sbomify.com/CVE-2026-33548/): MantisBT has Stored HTML Injection / XSS when displaying Tags in Timeline (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7615 and fix it if it is affected.

What it is: CVE-2017-7615 is a high-severity authentication bypass vulnerability in Mantisbt Mantisbt, published on 16 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-7615 exists.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 1.3.0-rc.2; fixed in 1.3.10
- mantisbt/mantisbt (Packagist): affected from 1.3.0-rc.2; fixed in 1.3.10
- mantisbt/mantisbt (Packagist): affected from 2.0.0; fixed in 2.2.4
- mantisbt/mantisbt (Packagist): affected from 2.0.0; fixed in 2.2.4
- mantisbt/mantisbt (Packagist): affected from 2.3.0; fixed in 2.3.1
- mantisbt/mantisbt (Packagist): affected from 2.3.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7615/ (Markdown: https://insights.sbomify.com/CVE-2017-7615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7615
- OSV: https://osv.dev/vulnerability/CVE-2017-7615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7615/
Summaries are generated and may contain mistakes; the official description above is the record.
