# CVE-2017-7620: MantisBT vulnerable to CSRF and Open Redirect attacks

> Attackers can exploit open redirects and permalink injection in MantisBT to bypass security controls or facilitate account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9x76-mp7r-2xc5

## What is CVE-2017-7620?

CVE-2017-7620 is a medium-severity vulnerability in Mantisbt Mantisbt, published on 21 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MantisBT before 1.3.11, 2.x before 2.3.3, and 2.4.x before 2.4.1 omits a backslash check in string_api.php and consequently has conflicting interpretations of an initial \/ substring as introducing either a local pathname or a remote hostname, which leads to (1) arbitrary Permalink Injection via CSRF attacks on a permalink_page.php?url= URI and (2) an open redirect via a login_page.php?return= URI.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-7620?

6 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 1.3.11 |
| `mantisbt/mantisbt` | Packagist | All versions | 1.3.11 |
| `mantisbt/mantisbt` | Packagist | From 2.0.0 | 2.3.3 |
| `mantisbt/mantisbt` | Packagist | From 2.0.0 | 2.3.3 |
| `mantisbt/mantisbt` | Packagist | From 2.4.0 | 2.4.1 |
| `mantisbt/mantisbt` | Packagist | From 2.4.0 | 2.4.1 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2017-7620?

Upgrade mantisbt/mantisbt to a fixed version for your release line: 1.3.11, 2.3.3 or 2.4.1.

## Is CVE-2017-7620 being exploited?

There is no known exploitation of CVE-2017-7620 in the wild and no public exploit code.

Public exploit code:

- Mantis Bug Tracker 1.3.10/2.3.0 - Cross-Site Request Forgery (exploitdb)

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7620 and fix it if it is affected.

What it is: CVE-2017-7620 is a medium-severity vulnerability in Mantisbt Mantisbt, published on 21 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7620 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 1.3.11
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 1.3.11
- mantisbt/mantisbt (Packagist): affected from 2.0.0; fixed in 2.3.3
- mantisbt/mantisbt (Packagist): affected from 2.0.0; fixed in 2.3.3
- mantisbt/mantisbt (Packagist): affected from 2.4.0; fixed in 2.4.1
- mantisbt/mantisbt (Packagist): affected from 2.4.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7620/ (Markdown: https://insights.sbomify.com/CVE-2017-7620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7620
- OSV: https://osv.dev/vulnerability/CVE-2017-7620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7620/
Summaries are generated and may contain mistakes; the official description above is the record.
