# CVE-2017-7656: Jetty vulnerable to cache poisoning due to inconsistent HTTP request handling (HTTP Request Smuggling)


- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2026-YD52185, DEBIAN-CVE-2017-7656, GHSA-84q7-p226-4x5w, UBUNTU-CVE-2017-7656

## What is CVE-2017-7656?

CVE-2017-7656 is a high-severity vulnerability in Debian Debian Linux, published on 26 Jun 2018. 

### Official description

In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled), HTTP/0.9 is handled poorly. An HTTP/1 style request line (i.e. method space URI space version) that declares a version of HTTP/0.9 was accepted and treated as a 0.9 request. If deployed behind an intermediary that also accepted and passed through the 0.9 version (but did not act on it), then the response sent could be interpreted by the intermediary as HTTP/1 headers. This could be used to poison the cache if the server allowed the origin client to generate arbitrary content in the response.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2017-7656?

4 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.3.24.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.3.24.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.11.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.11.v20180605 |

Products: Debian Debian Linux, Eclipse Jetty.

## How do I fix CVE-2017-7656?

Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.3.24.v20180605 or 9.4.11.v20180605.

## Is CVE-2017-7656 being exploited?

There is no known exploitation of CVE-2017-7656 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7656 and fix it if it is affected.

What it is: CVE-2017-7656 is a high-severity vulnerability in Debian Debian Linux, published on 26 Jun 2018. 
Exploitation: There is no known exploitation of CVE-2017-7656 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.3.24.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.3.24.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.11.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.11.v20180605

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7656/ (Markdown: https://insights.sbomify.com/CVE-2017-7656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7656
- OSV: https://osv.dev/vulnerability/CVE-2017-7656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7656/
Summaries are generated and may contain mistakes; the official description above is the record.
